REPORTS NOT PRINTING PROPERLY

Packn1
User
User
Posts: 12
Joined: Tue Dec 20, 2016 9:29 am

REPORTS NOT PRINTING PROPERLY

Post by Packn1 » Tue Jul 02, 2019 12:48 pm

running CMM MANAGER 3.8 SP1

Program runs fine and reports on screen just fine... same program also saving to PDF just fine and matches what is displayed if I review the file.
HOWEVER when physically printed it is missing the last 2 features! (We manually print, not automatic, and print from report tab ((displayed)) right after program finishes)

If I then hit print again it will work just fine and print the missing items!!! (First time I print will display pages 1-4 and when printing the same report changing nothing, not leaving the tab, shows 1-5) Does not matter which print button I use or ctrl+p

This just is not ok!! A feature was out that was not printed and the parts are over 1K each & we just lost 3 parts because of it!!!!

Not having the issue on all programs.
Anyone else having this issue?

Packn1
User
User
Posts: 12
Joined: Tue Dec 20, 2016 9:29 am

Re: REPORTS NOT PRINTING PROPERLY

Post by Packn1 » Tue Jul 02, 2019 5:30 pm

Made a vid of issue...
https://youtu.be/2UjfW4grUrw

WARNING be on lookout for this - for now we are going to compare the # of tolerance reports on screen to what printed before walking away with printed reports. (example = on screen at bottom of report = "#23 tolerance report" & bottom of printed is #21

Packn1
User
User
Posts: 12
Joined: Tue Dec 20, 2016 9:29 am

Re: REPORTS NOT PRINTING PROPERLY

Post by Packn1 » Wed Jul 03, 2019 1:27 pm

For anyone that cares...

The issue will only occur if:
#1 - Program is set to save/print to PDF.
#2 -The issue will then only occur if the final printed page is less that rough 15% used, (any more than that & the PDF printed page also gains a page and the problem goes away. )

There is some scaling issue between PDF & Printed and the way that CMM manager defaults to PDF printer after program ends and saves as pdf.

If you do not save to PDF in your programs you are fine. (DID NOT TEST ALL OTHER SAVING OPTIONS LIKE EXCEL ETC) But if you only view or print reports you are fine.

User avatar
CrashN8
Site Admin
Site Admin
Posts: 400
Joined: Thu Feb 09, 2017 4:07 pm

Re: REPORTS NOT PRINTING PROPERLY

Post by CrashN8 » Mon Jul 08, 2019 10:56 am

I wonder if this is related to Page Formatting? I will play with manipulating margins to see if I can reproduce. Also I heard some comments this morning in development office that someone has an idea of what my cause this problem. Either way, we are aware and looking into the issue. Thank you for reporting.

Edit - I've played with this quite extensively and cannot reproduce. Is it possible that your printer(s) have a different page size than what's configured in PDF printer? - i.e. one of the printers has a paper tray that contains legal size or A4 sized paper vs. standard 8 1/2 x 11 paper? I think we will need some files from you including Help Desk FIle, Program Run Results, and original Project file to troubleshoot this further.

User avatar
CrashN8
Site Admin
Site Admin
Posts: 400
Joined: Thu Feb 09, 2017 4:07 pm

Re: REPORTS NOT PRINTING PROPERLY

Post by CrashN8 » Mon Jul 08, 2019 11:48 am

Packn1 wrote:
Tue Jul 02, 2019 12:48 pm
This just is not ok!! A feature was out that was not printed and the parts are over 1K each & we just lost 3 parts because of it!!!!

Not having the issue on all programs.
Anyone else having this issue?
I would suggest that you take advantage of settings in the software to ISOLATE Out of Tolerance Report Printing or Saving per the settings shown below. You can find details on these settings in your Help Files.

I agree this is not acceptable... However I suspect this is related to Printer settings or Page Format and not directly to software.
OOT_print_save.jpg
You do not have the required permissions to view the files attached to this post.

Packn1
User
User
Posts: 12
Joined: Tue Dec 20, 2016 9:29 am

Re: REPORTS NOT PRINTING PROPERLY

Post by Packn1 » Wed Jul 10, 2019 5:36 pm

Another video… Notice I am showing 4 pages with pdf printer then when I set default to any other printer it needs 5. So CMM manager recognizes whatever the difference in requirements is BUT after RUN SAVING to pdf…. It is locking down the 4 page requirement and killing a page.
https://youtu.be/OFHeJTqTN50

This one I am printing to the very same printer twice!
First time is showing 4 pages (because of the default to PDF after RUN SAVING) then, after changing to appropriate printer I print it, THEN I hit print again without changing anything and it prints 5 pages. It is 100% CMM Manager problem.
https://www.youtube.com/watch?v=2UjfW4grUrw

Attached .jpg is what is happening when it only prints the 4 pages! Cut off 2 report items.... when it prints the second time it is correct and spits out the 5 pages needed.
bhzRsh.jpg
Here is the 4 page pdf
common.jpg
You do not have the required permissions to view the files attached to this post.

Packn1
User
User
Posts: 12
Joined: Tue Dec 20, 2016 9:29 am

Re: REPORTS NOT PRINTING PROPERLY

Post by Packn1 » Wed Jul 10, 2019 5:51 pm

N8 I sent the files to Medpurist already ... should I send all the files to you as well?

User avatar
CrashN8
Site Admin
Site Admin
Posts: 400
Joined: Thu Feb 09, 2017 4:07 pm

Re: REPORTS NOT PRINTING PROPERLY

Post by CrashN8 » Thu Jul 11, 2019 9:21 am

Packn1 wrote:
Wed Jul 10, 2019 5:51 pm
N8 I sent the files to Medpurist already ... should I send all the files to you as well?
I can retrieve files from Matt. We'll be in touch after we are able to reproduce this. So far, we are not seeing this on any system (15+) here in Columbus.

User avatar
CrashN8
Site Admin
Site Admin
Posts: 400
Joined: Thu Feb 09, 2017 4:07 pm

Re: REPORTS NOT PRINTING PROPERLY

Post by CrashN8 » Fri Jul 12, 2019 10:05 am

Packn1 - We are not able to reproduce this behavior in Columbus office. I suspect it is related to issue that was resolved in 3.9 related to PDF output and Printing... something to do with manipulating Windows Default Printer, thus causing print jobs to go to wrong printer sometimes. By any chance does the Report document for the faulty program fit onto 4 pages of PDF, but require 5 pages when printed? I email you and Nikon License Team to ask if your seat of CMM-Manager is eligible for upgrade to version 3.9.

Packn1
User
User
Posts: 12
Joined: Tue Dec 20, 2016 9:29 am

Re: REPORTS NOT PRINTING PROPERLY

Post by Packn1 » Fri Jul 12, 2019 11:16 am

Yes Nate the last pic I posted above is demonstrating the full 4 page PDF ...

Pic with 2 reports side by side is showing the printed results from this video where I print to the same printer twice. (right after the program finished, I print it then print it again to the same printer with 2 different results.)
https://www.youtube.com/watch?v=2UjfW4grUrw

Will upgrade and see if it clears the issue but is going to be at least a few days before I can find time. At 3.8 SP1 now

Post Reply